Temporäre as400 iSeries routing caches

Heute hatte ich mal wieder ein richtig schönes WTF.

Auf der iSeries scheint es einen Routingcache zu geben der auch nach Reboots bestehen bleibt.

Wir hatten eine Netzwerkumstellung, bei der der Gateway getauscht wurde und kamen auf einmal auf 2 Systemen nicht mehr an eine bestimmte IP.

Die aktuelle Routingtabelle hatte aber ordnungsgemäß nur einen Eintrag zum normalen Gateway hier.

An die aktuell fest eingetragene Routingtabelle kommt man per

==> go tcpadm

1. TCP/IP konfigurieren (Configure TCP/IP)

2. Mit TCP/IP-Leitwegen arbeiten (Work with TCP/IP routes)

Dann steht da so etwas:

Mit TCP/IP-Leitwegen arbeiten                        
 System:   xxx
Auswahl eingeben und Eingabetaste drücken.                                   
 1=Hinzufügen   2=Ändern   4=Entfernen   5=Anzeigen                         

Aus-                                    Nächster         Bevorzugte          
wahl  Leitwegziel      Teilnetzmaske    Hop              Schnittstelle       

 *DFTROUTE        *NONE            172.30.201.3     *NONE               

 Ende       
F3=Verlassen    F5=Aktualisieren   F6=Liste drucken   F11=Serviceart anzeigen
F12=Abbrechen   F17=Anfang         F18=Ende

Das System hier hat die 172.30.202.1 und ich wollte zur 172.25.202.1

Man möchte meinen, der traceroute geht jetzt über 172.30.201.3 und dann weiter wohin er soll.

Isser aber nicht, er ging auf die 172.30.208.1 und verendete da.

Großes Rätselraten was das denn soll, da an der Route schon Ewigkeiten nichts mehr geändert wurde.

Des Rätsels Lösung ist der Routingcache.

Der woher auch immer kommt und irgendwie entgegen meinem Verständnis von Caches nie gelöscht wird.

Dahin kommt man wie folgt:

==> go tcpadm

7. Mit TCP/IP-Netzstatus arbeiten (Work with TCP/IP network status)

2. TCP/IP-Leitweginformationen anzeigen (Display TCP/IP routes)

Da sieht man dann so etwas bevor einem die Kinnlade runterfällt:

TCP/IP-Leitweginformationen anzeigen                    
 System:   xxx
Auswahl eingeben und Eingabetaste drücken.                                   
 5=Details anzeigen                                                         

 Nächster          Leitweg             
Opt  Leitwegziel      Teilnetzmaske    Hop              vorhanden            
 127.0.0.0        255.0.0.0        *DIRECT            *YES               
 172.30.128.0     255.255.128.0    *DIRECT            *YES               
 172.30.128.0     255.255.128.0    *DIRECT            *YES               
 172.29.210.1     *HOST            172.30.208.1       *YES               
 172.29.202.3     *HOST            172.30.208.1       *YES               
 172.28.210.2     *HOST            172.30.208.1       *YES               
 172.28.210.1     *HOST            172.30.208.1       *YES               
 172.28.203.36    *HOST            172.30.208.1       *YES               
 172.28.203.32    *HOST            172.30.208.1       *YES               
 172.27.10.101    *HOST            172.30.208.1       *YES               
 172.27.2.1       *HOST            172.30.208.1       *YES               
 172.25.210.3     *HOST            172.30.208.1       *YES               
 172.25.210.2     *HOST            172.30.208.1       *YES               
 Weitere ...
F3=Verlassen   F9=Befehlszeile   F11=Leitwegart anzeigen   F12=Abbrechen     
F13=Sortieren nach Spalte   F20=IPv6-Leitwege anzeigen     F24=Weitere Tasten

Da stand meine 172.25.202.1 mit Gateway 172.30.208.1 drin.

Das geschulte Auge erkennt das fehlen einer Auswahl 4.

Also hab ich mal ins blaue geraten und Glück gehabt, man muss die Routen anlegen und kann Sie dann wieder löschen.

ADDTCPRTE RTEDEST(‘172.25.202.1’) SUBNETMASK(‘255.255.255.255’) NEXTHOP(‘172.30.208.1’)

und danach

RMVTCPRTE RTEDEST(‘172.25.202.1’) SUBNETMASK(‘255.255.255.255’) NEXTHOP(‘172.30.208.1’)

Ich liebe meine as400 🙂

Das System ist übrigens V5R4

Leave a Reply